ipv6 Lab 7 : IPV6 Tunnel IPv6ip

 LAB 7

IPv6 dan IPv4 tidak compatible satu sama lain, maka agar IPv6 dan IPv4 bisa hidup berdampingan salah satunya kita bisa menggunakan tunneling. 

Untuk lab kali ini kita akan menggunakan static point – to – point tunneling, ada dua metode yang bisa kita gunakan : 

- Manual Tunnel (IPv6IP) 

- GRE Tunnel 

Berikut konfigurasinya, 

seperti biasakita konfigurasi bagian dasar terlebih dahulu :

R1

R1(config)#int fastEthernet 0/0 
R1(config-if)#ip address 12.12.12.1 255.255.255.0 
R1(config-if)#no shutdown 
R1(config-if)#exit 
R1(config)#int loopback0 
R1(config-if)#ipv6 address 1::1/128 
R1(config-if)#exit 
R1(config)#router rip 
R1(config-router)#version 2 
R1(config-router)#network 12.12.12.0 
R1(config-router)#no auto-summary 
R1(config-router)#exit 

R2

R2(config)#int fastEthernet 0/0 
R2(config-if)#ip add 12.12.12.2 255.255.255.0 
R2(config-if)#no shutdown 
R2(config-if)#exit 
R2(config)#int fastEthernet 0/1 
R2(config-if)#ip add 23.23.23.2 255.255.255.0 
R2(config-if)#no shutdown 
R2(config-if)#exit
R2(config)#router rip 
R2(config-router)#version 2 
R2(config-router)#network 12.12.12.0 
R2(config-router)#network 23.23.23.0 
R2(config-router)#no auto-summary 
R2(config-router)#exit

R3

R3(config)#int f0/0 
R3(config-if)#ip add 23.23.23.3 255.255.255.0 
R3(config-if)#no shutdown 
R3(config-if)#exit 
R3(config)#int lo0 
R3(config-if)#ipv6 address 3::3/128 
R3(config-if)#exit 
R3(config)#router rip 
R3(config-router)#version 2 
R3(config-router)#network 23.23.23.0 
R3(config-router)#no auto-summary 
R3(config-router)#exit 

Konfigurasi Tunnel 

R1

R1(config)#int tunnel 0 
R1(config-if)#ipv6 address 13::1/64 
R1(config-if)#tunnel source 12.12.12.1 
R1(config-if)#tunnel destination 23.23.23.3 
R1(config-if)#tunnel mode ipv6ip 
R1(config-if)#exit 

R3

R3(config)#int tunnel 0 
R3(config-if)#ipv6 address 13::2/64 
R3(config-if)#tunnel source 23.23.23.3 
R3(config-if)#tunnel destination 12.12.12.1 
R3(config-if)#tunnel mode ipv6ip 
R3(config-if)#exit

R1

R1#sh ipv6 int brief 
Loopback0 [up/up] 
 FE80::C801:5FF:FE31:8 
 1::1 
Tunnel0            [up/up] 
 FE80::C0C:C01 
 13::1 

R3

R3#sh ipv6 interface brief 
Loopback0                 [up/up] 
 FE80::C803:5FF:FE4F:8 
 3::3 
Tunnel0                       [up/up] 
 FE80::1717:1703 
 13::2 

R1

R1#sh int tunnel 0 | i protocol 
Tunnel0 is up, line protocol is up 
 Tunnel protocol/transport IPv6/IP 
 0 unknown protocol drops 

R3

R3#sh int tunnel 0 | i protocol 
Tunnel0 is up, line protocol is up 
 Tunnel protocol/transport IPv6/IP 
 0 unknown protocol drops 

Cek ping antar rip tunnel 

R1

R1#ping 13::2 
Sending 5, 100-byte ICMP Echos to 13::2, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/21/32 ms

R3

R3#ping 13::1 
Sending 5, 100-byte ICMP Echos to 13::1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/43/44 ms 

Konfigurasi Routing ke IP Loopback

R1

R1(config)#ipv6 route 3::3/128 13::2 

R3

R3(config)#ipv6 route 1::1/128 13::1

R1

R1#sh ipv6 route 
IPv6 Routing Table - Default - 5 entries 
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route 
 B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1 
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP 
 EX - EIGRP external 
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2 
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2 
LC 1::1/128 [0/0] 
 via Loopback0, receive 
S 3::3/128 [1/0] 
 via 13::2 
C 13::/64 [0/0] 
 via Tunnel0, directly connected 
L 13::1/128 [0/0] 
 via Tunnel0, receive 
L FF00::/8 [0/0] 
 via Null0, receive 

R3

R3#sh ipv6 route 
IPv6 Routing Table - Default - 5 entries 
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route 
 B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1 
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP 
 EX - EIGRP external 
 O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2 
 ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2 
S 1::1/128 [1/0]
via 13::1 
LC 3::3/128 [0/0] 
 via Loopback0, receive 
C 13::/64 [0/0] 
 via Tunnel0, directly connected 
L 13::2/128 [0/0] 
 via Tunnel0, receive 
L FF00::/8 [0/0] 
 via Null0, receive 

Test ping 

R1

R1#ping 3::3 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds: 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/33/40 ms 

R3

R3#ping 1::1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 1::1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/40/40 ms


Comments